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Charts 
Charts present data, relationships, or trends 
graphically. Illustrating information with charts can 
help with data comprehension as well as interpretation 
and analysis. Excel offers several chart options to suit 
various types of data sets and design preferences. 

In this module, learn how to create, edit, and format 
professional-looking charts so you can present complex 
data in a way that is meaningful to your audience. 

Objectives 
Create Charts 

Move and Resize 

Chart Types 

Layout and Style 

Titles and Legends 

Gridlines, Labels, and Data Tables 

Emphasize Chart Data 

Modify Chart Data 

Filter Charts 

Trendlines 

Dual Axis Charts 

Chart Templates 

Sparklines 
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Create Charts 

Charts are a great way to share data and information in a graphical way. The foundation of charts is the data 
they illustrate. Choosing the right data is the first and most important step in creating a chart. 

Choose the Right Chart 
Once you’ve determined the results you want your chart to display, choose the chart that best suits this 
purpose. The most popular charts are column, line, pie, and bar charts. 

 

  

Chart Types in Excel 

Column Column charts are used when you want to compare different values vertically 
side-by-side. Each value is represented in the chart by a vertical bar. If there 
are several series, each series is represented by a different color. 

Line Line charts are used to illustrate trends over time. Each value is plotted as a 
point on the chart and is connected to other values by a line. Multiple items 
are plotted using different lines. 

Pie Pie charts are useful for showing values as a percentage of a whole. The values 
for each item are represented by different colors. Limit pie charts to eight 
sections. 

Bar Bar charts are just like column charts, except they display information in 
horizontal bars rather than in vertical columns. 

Area Area charts are the same as line charts, except the areas beneath the lines are 
filled with color. 

XY (Scatter) Scatter charts are used to plot clusters of values using single points. Multiple 
items can be plotted by using different colored points or different point 
symbols. 

Stock Stock charts are effective for reporting the fluctuation of stock prices, such as 
the high, low, and closing points for a certain day. 

Surface A surface chart is useful for finding optimum combinations between two sets of 
data. Colors and patterns indicate values that are in the same range. 

Radar Radar charts compare the aggregate values of multiple data series. 
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Create a Chart 
Select the data you want to 
include in your chart. 

Make sure to include your 
column names if you want 
them to be in the chart. 

Click the Insert tab. 

Select a chart type in the 
Charts group. 

Tip: To see all available chart 
types click the Charts dialog 
box launcher. The Insert Chart 
dialog box appears, displaying 
every chart type that is 
available. 

Click a chart subtype. 

The chart appears in the worksheet 
and the Chart Tools appear on the 
Ribbon. The Chart Tools include three 
new tabs—Design, Layout and 
Format—that help you modify and 
format the chart. 
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Create a Recommended Chart 
Many times, it’s hard to tell what type of chart will best illustrate your data. To help make your decision 
easier, Excel offers Recommended Charts. This tool looks at the data you have selected and suggests a few 
charts that will represent it well. 

Select the data you want to 
include in your chart. 

Click the Insert tab. 

Click Recommended Charts. 

Excel recommends charts 
based on the data you 
selected. 

Select the type of chart you 
want to use. 

Once you select a chart, a 
preview and description 
appear at the right. 

Click OK. 

The recommended chart is inserted 
into the worksheet. 
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Move and Resize 

Usually, you will have to adjust a chart after it is inserted to ensure it doesn’t cover up data on the 
worksheet. You can resize a chart, move it within the worksheet, or move it to another worksheet. 

Move a Chart 
Click the chart to select it. 

Click the chart’s border and 
drag it to the new location. 

Tip: Make sure the four-
headed arrow is activated 
before clicking and dragging. 

The chart is moved to where you 
dragged it. 

 

 

 

 

Move Charts to a Chart Sheet 
If you don’t want your chart on the same sheet as the data, you can move it to its own worksheet. 

Select the chart you want to 
move. 

Click the Move Chart button 
on the Design tab. 

Select New sheet. 

Type a name for the sheet. 

Click OK. 

The chart is moved to its own 
worksheet. 
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Resize a Chart 
Eight sizing handles appear along the chart edges once it is selected. Sizing handles are used to change the 
size of charts and other objects. 

Click the chart to select it. 

Click and drag the chart’s sizing 
handle. 

Tip: Make sure the two-headed 
arrow is activated before 
clicking and dragging. 
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Chart Types 

Different types of charts are better for presenting different types of information. For example, a column 
chart is great for comparing values of different items, but not for illustrating trends or relationships. If you 
find that a chart you’ve created isn’t the best fit for your data, you can switch to a different chart type. 

Change the Chart Type 
Select the chart you want to 
change. 

Click the Design tab. 

Click Change Chart Type. 

Shortcut: Right-click a chart 
and select Change Chart Type 
from the menu. 

The Change Chart Type dialog 
box appears. It shows the 
different types of charts 
available. 

Select a different chart option. 

Click OK. 

  



16  

Switch Row/Column Data 
You can switch the rows and columns of data in a chart so they appear in opposite positions. 

Select the chart. 

Click the Design tab. 

Click the Switch Row/Column 
button. 
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Layout and Style 

An easy way to change the look and feel of a chart is by applying one of the built-in layouts or styles that are 
available in Excel. 

Apply a Chart Layout 
Built-in chart layouts can quickly adjust the overall layout of a chart with different combinations of titles, 
labels, and chart orientations. 

Select the chart you want to 
format. 

Click the Design tab. 

Click the Quick Layout button. 

Select the layout you want to 
use. 

The selected layout is applied to the 
chart. 
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Apply a Chart Style 
Built-in chart styles allow you to adjust the format of several chart elements all at once. Styles quickly 
change colors, shading, and other formatting properties. 

Select the chart. 

Click the Design tab. 

Click the Chart Styles More 
button. 

Tip: If the style you want to use 
is already displayed in the 
gallery, there is no need to 
expand the menu, just select it. 

Select a new style. 

 
 
 
 
 
 
 

Change Colors 
You can maintain the general look of a style while updating just the colors to better suit your needs. 

Select the chart.  

Click the Design tab.  

Click the Change Colors 
button. 

Select a new color set. 

The new color set is applied to the 
chart. 



 © 2022 CustomGuide, Inc. 19 

Titles and Legends 

Besides using built-in chart layouts, you can manually add or edit individual chart labels such as the chart 
title or axis titles. 

Change the Chart Title 
The chart title often appears above the chart and is used to describe the data that’s being presented. You 
can add a completely new chart title or simply change the text of an existing one.  

Select the chart. 

Right-click the chart title. 

Click the Edit Text button. 

Shortcut: Double-click the 
chart title to make it editable. 

Enter the new chart title. 

Click anywhere outside the 
title area. 
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Add Axis Titles 
The axis titles describe for viewers the category of data that’s being represented. Without them, it can be 
difficult to accurately portray information. 

Select the chart. 

Click the Chart Elements 
button. 

Tip: Hover the mouse over the 
label options in the list to 
preview them on your chart 
before making your selection. 

Select the Axis Titles check 
box. 

A text box is added for both 
the vertical and horizontal 
axes. 

Enter descriptive axis titles. 

Click outside the title area. 

 

 

Position the Chart Legend 
Usually when a chart is created, a legend is added automatically. The legend identifies what information is 
portrayed in the chart’s plot area. 

Select the chart. 

Click the Chart Elements 
button. 

Click the Legend list arrow. 

Be careful not to click the word 
“Legend” or it will turn it off, 
just hover over it until the list 
arrow appears. 

Select a position for the 
legend. 

Tip: You can also click the Add 
Chart Element button on the 
Design tab. 
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Chart Elements  
Chart and axis titles are just a couple of the chart elements that are customizable. This table describes 
everything you can modify. 

Chart Element Description 

Axes Identifies the values being charted. Most charts have a vertical and 
horizontal axis. 

Axis Titles Provides a descriptive label for the data being charted on the axis. 

Chart Title Describes the data being presented in a chart.  

Data Labels Displays data from the cells of the worksheet on the plot area of the chart. 

Data Table A table added next to the chart that shows the worksheet data the chart is 
illustrating.  

Error Bars Helps you quickly identify standard deviations and error margins. 

Gridlines Horizontal and/or vertical lines added to a chart to make data easier to 
read. 

Legend  The chart’s key. Describes the data being presented in the plot area of the 
chart. 

Trendline Identifies the trend of the current data, not actual values. Can also 
identify forecasts for future data. 
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Gridlines, Labels, and Data Tables 

Adding elements like gridlines, labels, and data tables help viewers more easily identify what’s being 
presented. 

Show Chart Gridlines 
Gridlines are the lines in the background of a chart that correspond to the values in the chart. In column and 
bar charts, gridlines make it easier to compare the values in the chart. 

Select the chart you want to 
format. 

Click the Chart Elements 
button. 

Click the Gridlines list arrow. 

Be careful not to click the word 
Gridlines or all the gridlines 
will turn off, just hover over it 
until the list arrow appears. 

Select the set of gridlines you 
want to show. 

 

 

 

Add Data Labels 
Use data labels to label the values of individual chart elements. 

Select the chart. 

Click the Chart Elements 
button. 

Click the Data Labels check 
box. 

Tip: In the Chart Elements 
menu, click the Data Labels list 
arrow to change the position of 
the data labels. 
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Display a Data Table 
A data table is a table that contains the data and headings from your worksheet that comprises the chart 
data. 

Select the chart. 

Click the Chart Elements 
button. 

Select the Data Table check 
box. 

Tip: To edit the data table 
settings, hover over Data Table 
in the Chart Elements menu, 
click the list arrow, and select 
More Options. 

A table with all the data represented in 
the chart is added below the chart’s 
plot area. 



24  

Emphasize Chart Data 

One way to emphasize data is to change the formatting of a specific piece of data or a data series so it 
stands out from the rest of the chart. 

Change the Color of a Data Series 
You can make a data series stand out by applying a different color to the series. 

Select the chart you want to 
format. 

Select the data series you want 
to format. 

Click the Format tab. 

Click Format Selection. 

Shortcut: Right-click a data 
series and select Format Data 
Series from the contextual 
menu. 

The formatting pane appears 
at the right. 

Click the Fill & Line button. 

Click Fill to expand the section. 

Click the Fill Color button. 

Select a color. 

The formatting is applied to the entire 
data series. 
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Format Other Chart Areas 
You can also switch the chart element you want to format from right within the formatting panel. 

Click the Series Options menu 
arrow. 

Select a chart area to format. 

Select a type of format you 
want to apply. 

Close the Format pane. 
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Modify Chart Data 

Once you see data in a chart, you may find there are some tweaks and changes that need to be made. Here 
are a few ways to change the data in your chart. 

Add a Data Series 
If you need to add additional data from the spreadsheet to the chart after it’s created, you can adjust the 
source data area. 

Select the chart. 

In the worksheet, click a sizing 
handle for the source data and 
drag it to include the additional 
data. 

Tip: The new data needs to be 
in cells adjacent to the existing 
chart data. 
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Rename a Data Series 
Charts are not completely tied to the source data. You can change the name and values of a data series 
without changing the data in the worksheet. 

Select the chart. 

Click the Design tab. 

Click the Select Data button. 

Select the series you want to 
change under Legend Entries 
(Series). 

Click the Edit button. 
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Type the label you want to use 
for the series in the Series 
name field. 

Click OK. 

Click OK again.  

The name is updated in the chart, but 
the worksheet data remains 
unchanged. 
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Reorder a Data Series 
You can also change the order of data in the chart without changing the order of the source data. 

Select the chart. 

Click the Design tab. 

Click the Select Data button. 

From the Select Data Source 
dialog box, select the data 
series you want to move. 

Click the Move Up or Move 
down button. 

Click OK. 

The chart is updated to display the new 
order of data, but the worksheet data 
remains unchanged. 
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Filter Charts 

You may occasionally want to turn off certain parts of your chart, to focus in on specific data. This can be 
accomplished with filtering. 

Filter a Chart 
Select the chart you want to 
filter. 

Click the Chart Filters button. 

Select the item(s) you want to 
display or hide. 

Click Apply. 

All the data remains in the worksheet, 
but only the selected values appear in 
the chart. 

 

 

 

 

Remove a Filter 
When you need to see all your data again, clear the filter. 

Select the chart with the filter 
you want to remove. 

Click the Chart Filters button. 

For the data that’s filtered, 
click the Select All check box 
twice. 

Tip: Clicking the check box 
once deselects everything. 
Clicking it again turns 
everything on again. 

Click Apply. 
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Trendlines 

Trendlines help you see an overall picture of data over time. They can even be used to forecast future trends 
and make predictions. 

Choose a Trendline 
Trendlines aren’t available with all types of charts. However, if you are using an area, bar, line, column, 
stock, scatter, or bubble chart that’s 2-dimentional, a trendline can be applied. There are six different types 
available. Use the table below to determine the right type of trendline for your chart and data.  

  

Chart Types in Excel 

Exponential Exponential trendlines work only for data sets with positive values. They’re 
best for data that increases or decreases at a quick rate.  

Linear Linear trendlines are best for simple sets of data where the data points are in a 
line that increase or decrease at a steady rate. 

Logarithmic If your data increases or decreases quickly and then evens out, a logarithmic 
trendline is the best to use. They are curved trendlines and can be used for 
charts with both positive and negative values.   

Polynomial Polynomial trendlines are curved lines for data with positive values. Use these 
if your data set fluctuates and you need to assess the ups and downs of a large 
set of data. 

Power Power trendlines are also curved lines for data with positive values. If your data 
increases at a specific rate, power trendlines are the best to use.  

Moving Average If your data has large fluctuations, a moving average trendline is best. They 
help neutralize variations to give you a better idea of the underlying trend.  
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Add a Trendline 
Select the chart where you 
want to add a trendline. 

Click the Design tab. 

Click Add Chart Element. 

Select Trendline. 

Select the type of trendline you 
want to apply to the chart. 

  



 © 2022 CustomGuide, Inc. 33 

Edit a Trendline 
If the trendline doesn’t give you all the information you need, there are some ways you can modify it. 

Right-click the trendline. 

Select Format Trendline. 

The Format Trendline pane 
opens on the right. Here, you 
can modify the settings for the 
current trendline, change the 
trendline type, and control 
formatting options. 

Modify the trendline options to 
suit your needs. 

Click the Format Trendline 
pane's Close button. 
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Dual Axis Charts 

Dual axis charts, also called combo charts, are great when you have two different kinds of information to 
present in the same chart. For example, you can have a column chart representing sales data and a line 
chart representing commission amounts displayed together. 

Create a Dual Axis Chart 
Select the data you want to 
include in the chart. 

Click the Insert tab. 

Click the Combo button. 

Select Create Custom Combo 
Chart. 

The default combo chart 
doesn’t include a secondary 
axis to label the values of the 
second data set. It’s best to 
turn this on to make the data 
clear for chart viewers. 

Click the Secondary Axis box 
for the data you want to 
display on the alternate axis. 

Tip: You can change the chart 
type for each series to anything 
you want. Use the menus in 
the Chart Type column to 
select the chart types you want 
to use. 

Click OK. 
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Add Secondary Axis Titles 
By default, the primary and secondary axis values are not labeled in the chart. Adding labels helps clarify the 
data being presented. 

Select the dual axis chart. 

Click the Chart Elements 
button. 

Select the Axis Titles check 
box. 

Type a name in each axis text 
box. 

The primary and secondary axis titles 
are added to the chart. 
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Chart Templates 

If you find you are frequently creating the same type of charts with customized layouts and formatting, save 
yourself some time and create a chart template to reuse in the future. 

Save a Chart as a Template 
When you save a chart as a template, that chart’s properties are saved for easy future use. 

Right-click the chart you want 
to save as a template. 

Select Save as Template. 

Type a file name for the 
template. 

When Excel is installed on your 
computer, it automatically 
creates a special folder to store 
the templates you create, but 
you can select a different 
folder if you’d like. 

Click Save. 

  



 © 2022 CustomGuide, Inc. 37 

Create a New Chart from a Template 
Once you’ve saved a template, you can use that template to create a new chart. 

Navigate to the sheet where 
you want to use the chart 
template. 

Select the data you want to 
chart. 

Click the Insert tab on the 
Ribbon. 

Click the Charts dialog box 
launcher. 

Click the All Charts tab. 

Select the Templates folder in 
the list on the left. 

Select a template to use. 

Tip: If you no longer need a 
template, click the Manage 
Templates button to delete it. 

Click OK. 
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Sparklines 

Sparklines provide a way to chart information in the individual cells of a worksheet. They are a great way to 
show a snapshot of the worksheet data. 

Insert Sparklines 
Select the cells you want to 
summarize. 

Click the Insert tab. 

Click the Sparklines button. 

Select a sparkline type. 

• Line: Shows trends in the 
data over time. 

• Column: Shows differences 
in quantity. 

• Win/Loss: Shows gains or 
losses.  

The Create Sparklines dialogue 
box appears. When a cell range 
is already selected, the Data 
Range field is automatically 
populated. If you didn’t select 
a range previously, enter it in 
the Data Range field. 

Click in the Location Range 
field. 

Select the cell where you want 
the sparkline to appear. 

Click OK. 

Tip: You can change the 
sparkline’s style by selecting it, 
clicking the Design tab, and 
selecting a style from the Style 
Gallery. 

A Sparkline is added to the worksheet. 
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Print and Distribute 
At times, the best way to share your Excel data with 
others is to print it. You can configure your workbook 
to only print specific portions of your data. In addition, 
you can adjust the print scale to the right zoom level so 
your data set properly fills the space of a given paper 
size. If you choose to distribute your file electronically, 
there are steps you can take to ensure your document 
is optimized for others to consume. This module covers 
the options that are most important when printing or 
electronically distributing data from Excel. 

Objectives 
Page Size and Scale 

Print Area 

Page Breaks 

Print Titles, Gridlines, and Headings 

Headers and Footers 

Margins and Orientation 

Inspect for Issues 
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Page Size and Scale 

If you plan to print a worksheet on paper that isn’t letter size, you’ll need to select a different paper size in 
Excel. You can choose to adjust the scale of your printed worksheet so that the printed data stretches or 
shrinks to fit the number of pages you specify. 

Change Page Size 
Most people normally print on standard letter-sized (8.5” x 11”) paper, but Excel can print on many other 
paper sizes. 

Click the Page Layout tab. 

Click the Size button. 

Select a page size. 

Tip: If you don’t see the paper 
size you need, select More 
Paper Sizes. 
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Change Print Scale 
If you have a data range that’s too wide or tall for a page, scale it to ensure it fits correctly. 

Click the Page Layout tab. 

Click the Scale to Fit dialog box 
launcher. 

The Scaling section has two 
options you can choose from 
to adjust the worksheet’s scale 
for printing: 

• Adjust to: Enter a 
percentage or use the arrow 
buttons to stretch or shrink 
the printed output to a 
percentage of its actual size. 

• Fit to: Specify the number of 
pages wide and tall you 
want the printed data to 
occupy. Excel will either 
shrink the data to fit on 
fewer pages or expand it to 
fill additional pages. 

Specify the scaling options you 
want to use. 

Click OK. 
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Print Area 

There are two ways to specify the workbook data that is printed: setting the print area and adjusting the 
page breaks. 

Set the Print Area  
Sometimes you may only want to print part of a worksheet. You can define an area so that any time you 
print, only that cell range is printed. 

Select the cells you want to 
print. 

Click the Page Layout tab. 

Click the Print Area button. 

Select Set Print Area. 

Tip: Once a print area is set, 
add additional print areas by 
selecting the additional cells, 
clicking the Print Area button, 
and selecting Add to Print 
Area. 

A dark gray border appears around the 
print area. When you print, only the 
cells within that range appear on the 
page. 

Remove a Print Area 
Click the Page Layout tab. 

Click the Print Area button. 

Select Clear Print Area. 

The print area is cleared and the entire 
worksheet will print once again. 
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Page Breaks 

Excel automatically breaks up the page based on the margins and other page settings, but it’s also possible 
to adjust these page breaks or add alternative breaks to divide a worksheet into separate pages for printing. 

Adjust Page Breaks 
Click the View tab. 

Click the Page Break Preview 
button. 

Shortcut: Click the Page Break 
Preview button on the status 
bar. 

The worksheet appears in Page 
Break Preview view. 

To move a page break, click 
and drag it to a new location. 

Tip: Dashed lines indicate automatic 
page breaks, while solid lines represent 
page breaks that you have changed or 
added. 
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Print Titles, Gridlines, and Headings 

You can specify rows and columns to repeat on each printed page. You can also select whether you want to 
print cell gridlines and row and column headings. 

Print Row or Column Titles 
The Print Titles command allows you to designate certain rows and columns to repeat on every printed 
page. 

Click the Page Layout tab. 

Click the Print Titles button. 

Click in either the Rows to 
repeat at top or Columns to 
repeat at left field. 

Select the row or column you 
want to print on each page.  

Click OK when you’re finished. 
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Print Gridlines and Headings 
The letters and numbers that serve as the row and column headings don’t print by default. Neither do the 
worksheet gridlines. You can turn them on for printing if needed. 

Click the Page Layout tab. 

Click the Print Titles button. 

Under Print, click the Gridlines 
check box to show or hide 
gridlines. 

Select the Row and column 
headings check box to show or 
hide row and column headings. 

Click OK when you’re finished. 
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Headers and Footers 

You can use a header to include the same information at the top of every printed page or a footer to include 
information at the bottom of every page. You can enter your own headers or footers, insert built-in ones, or 
insert specific elements such as pictures or page numbers. 

Add a Header or Footer 
Click the Insert tab. 

Click the Text button. 

Select Header & Footer. 

The Header & Footer view 
displays and the header is 
active. 

Tip: You can also access the 
header and footer by clicking 
the View tab and clicking the 
Page Layout View button. 

Click in the header section 
where you want to add text.  

Enter custom text or select a 
pre-defined header from the 
Header & Footer Elements 
group or Header menu. 

To view the footer, click the Go 
to Footer button. 
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Click in the footer section 
where you want to add text. 

Enter custom text or select a 
pre-defined footer from the 
Header & Footer Elements 
group or Footer menu. 

Tip: Headers and footers can be 
formatted using the commands in the 
Font group on the Home tab. 

 

 

 

 

Header & Footer Elements Group Options 
The Header & Footer Elements group has a variety of pre-defined options you can use. 

  

Button Description 

Page Number Displays the correct page number for each page. 

Number of Pages Displays the total number of pages in the worksheet. 

Current Date Displays the current date. 

Current Time Displays the current time of day. 

File Path Displays the workbook’s name and file path. 

File Name Displays the workbook’s name. 

Sheet Name Displays the worksheet’s name. 

Picture Opens the Insert Picture dialog box, where you can browse for and insert a 
picture file. 

Format Picture Is only available once a picture has been inserted; this button allows you to 
adjust the picture’s size, brightness or contrast. 
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Adjust the Header and Footer Height 
Since the amount of content entered in a header or footer can vary, the height may need to be adjusted to 
fit all the text. 

Click the Page Layout tab. 

Click the Margins button. 

Select Custom Margins. 

Enter a new height for the 
header or footer. 

Click OK. 

The header and footer heights are 
adjusted and to accommodate the 
amount of content entered. 
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Margins and Orientation 

Margins are the empty space between the worksheet data and the left, right, top, and bottom edges of the 
printed page. You can manually adjust them to add more or less space around your worksheet data. 

Set Print Margins 
By default, the margins are 0.75 inches at the top and bottom, and 0.70 inches to the left and right. 

Click the Page Layout tab. 

Click the Margins button. 

Select the margin size you 
want to use from the list. 

Tip: If you don’t see a margin 
size that works, select Custom 
Margins to display the Page 
Setup dialog box. Here you can 
set your own custom margins. 

 

 

 
 

Set Page Orientation 
Portrait orientation is the default setting for printing worksheets, but you may want to use landscape 
orientation instead. 

Click the Page Layout tab. 

Click the Orientation button. 

Select an orientation option:  

• Portrait: In Portrait 
orientation, the paper is 
taller than it is wide—like a 
portrait painting. 

• Landscape: In Landscape 
orientation, the paper is 
wider than it is tall—like a 
landscape painting. 
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Inspect for Issues 

Excel has several features that help you make sure workbooks look and work the way you want them to 
before you distribute them to others. 

Excel comes with many options that help you prepare a workbook for distribution. 

Inspect a Workbook 
Check the workbook for hidden information, such as personal information; custom XML data; and other 
hidden or embedded information. This hidden information has the potential to reveal details about your 
organization or about the workbook itself that you might not want to share publicly. You can remove this 
hidden information before you share the workbook with other people. 

Click the File tab. 

Click Info. 

Click Check for Issues. 

Select Inspect Document. 
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Click Yes. 

There’s a variety of items you 
can check for within your 
workbook. Look through the 
list and identify the hidden 
content you want to inspect. 

Check the box for the items 
you want to inspect. 

Click Inspect. 
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Click Remove All next to the 
Items you want to remove. 

Click Close. 

The hidden data is removed from the 
workbook and will not been seen by 
others. 

 

 

 

 

 

 

Accessibility Issues 
The Accessibility Checker looks for anything that people with disabilities might find difficult to read. It even 
tells you why you'd want to fix the detected issue. 

Click the File tab. 

Click Info. 

Click Check for Issues. 

Select Check Accessibility. 
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Click an item in the 
Accessibility Checker pane. 

Excel jumps to the sheet with the 
problematic object and selects it so 
you can easily make changes. 

 

 

 

 

 

 

Compatibility Issues 
If you’ll be sharing your workbook with others who have an earlier version of Excel, you’ll want to run the 
Compatibility Checker to detect any information that may not be available to those individuals. 

Click the File tab. 

Click Info. 

Click Check for Issues. 

Select Check Compatibility. 

Excel 2019 has some features that 
aren’t available in earlier versions of 
the software. The Compatibility 
Checker identifies these and lets you 
know what will happen to the 
worksheet elements if the file is 
opened in another version of Excel. 
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Click OK. 
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Intermediate Formulas 
In Excel, you can add references to data from another 
worksheet, whether it exists in your current workbook 
or an external workbook. While absolute references 
remain constant, relative references are contextual to 
the location of the cell that contains the formula. 

The formulas covered in this module will help you 
simplify tedious or complex tasks. Learn how to merge 
text from multiple cells into one using the 
CONCATENATE function or calculate monthly payments 
for a large purchase using the PMT function. Dates and 
times can also be used in formulas to make calculations 
dealing with time a breeze. 

Objectives 
Reference External Worksheets 

Absolute and Relative References 

Order of Operations 

Cell and Range Names 

Insert Functions 

CONCAT Function 

PMT Function 

Display Formulas 

Date Formulas 
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Reference External Worksheets 

References to cells or cell ranges in other worksheets are called external references. One of the most 
common reasons for using external references is to create a worksheet that summarizes the totals from 
other worksheets. For example, a workbook might contain twelve worksheets—one for each month—and 
an annual summary worksheet that references and totals the data from each monthly worksheet. 

Reference Another Worksheet 
Click the cell where you want 
to insert the reference. 

Type = to start building the 
reference. 

Select the worksheet that 
contains the cell you want to 
reference. 

Tip: A worksheet reference in a 
formula has an exclamation 
point (!) after the sheet name. 

Select the cell you want to 
reference. 

Click or press Enter. 

The value from the other worksheet 
appears in the selected cell. 
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Reference Another Workbook 
You can also reference cells from completely different files. 

Click where you want to insert 
the reference. 

You’ll need to open the 
workbook that contains the 
data you want to reference 
before entering the formula. 

Type = and start building the 
reference. 

Click on the Excel icon in the 
task bar. 

Select the workbook with the 
cell(s) you want to reference. 

Select the cell(s) you want to 
reference. 

Click or press Enter. 

Tip: If you move, delete, or 
rename the file you 
referenced, your formula will 
break. 

The value from the other workbook 
appears in the worksheet. 

When another workbook is referenced 
in a formula, the file name appears in 
brackets like these: [ ]. 
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Absolute and Relative References 

Formulas can contain numbers, like 5 or 8, but more often they reference the contents of cells. A cell 
reference tells Excel where to look for values you want to use in a formula. For example, the formula 
=A5+A6 adds the values in cells A5 and A6. 

Using cell references is useful because if you change the values in the referenced cells, the formula result 
automatically updates using the new values. There are two types of cell references: relative and absolute. 

Relative References 
Relative references refer to cells in relation to the location of the cell that contains the formula. When the 
formula is moved, it references new cells based on their location. Relative references are the default type of 
references in Excel. 

Copy the formula in an existing 
cell that you want to paste 
elsewhere in the worksheet. 

Paste the formula in the 
desired cells. 
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Select a cell that contains the 
pasted formula. Use the 
formula bar to verify the cell 
references have updated 
relative to where the formula 
was pasted. 

In the cell(s) where the formula was 
pasted, the cell reference updates for 
the current row and/or column. 
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Absolute References 
Absolute references always refer to the same cell, even when the formula is copied and pasted. Absolute 
references are indicated with dollar signs in formulas (e.g. $A$1). 

Select the cell that contains a 
cell reference you want to 
convert to an absolute 
reference. 

In the formula bar, add dollar 
signs ($) to the reference you 
want to remain absolute. 

• Absolute column and row 
reference ($A$1): The 
column and row remain 
constant no matter where 
the formula is pasted.  

• Absolute column reference 
($A1): The column remains 
absolute no matter where 
the formula is pasted, but 
the row updates relatively. 

• Absolute row reference 
(A$1): The row remains 
absolute no matter where 
the formula is pasted, but 
the column updates 
relatively. 

Shortcut: Click in any cell 
reference in the formula bar 
and press F4 to convert it to an 
absolute reference. Continue to 
press F4 to change the type of 
absolute reference. 
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Order of Operations 

Formulas can contain several values, such as 81 and 3.5; cell references, such as B5 and C1:D11; operators, 
such as * (multiplication) and + (addition); and functions, such as SUM and AVERAGE. When you combine 
several operations and functions into a single formula, Excel performs the operations in a predetermined 
order, known as the order of operations. 

When a formula contains several operators with the same precedence, Excel calculates the formula from left 
to right. You can change the order by enclosing the part of the formula you want Excel to calculate first in 
parentheses. 

How Excel Performs the Order of Operations 
The table below explains the order in which Excel performs calculations in a formula. A mnemonic device 
you can use to remember the order of operations is ‘Please Excuse My Dear Aunt Sally’. 

 

Operation Example Memory Device 

Parentheses 10 + (6-2) / 2^2 Please 

Exponents  10 + 4 / 2^2 Excuse 

Multiplication and 
Division 

10 + 4/4 My  
Dear 

Addition and 
Subtraction 

10 + 1 Aunt 
Sally 

Result 11  
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Cell and Range Names 

Cell references can be confusing, especially when you're working with formulas. However, cell and range 
names can help. You can define a name for a cell, cell range, non-adjacent cells, formula, constant, or table. 

For example, you could name the cell range B16:H16 “Total Sales.” Then, instead of totaling sales with the 
formula =SUM(B16:H16), you could use the defined name to create the more readable formula, 
=SUM(TotalSales). 

Create a Name 
Select the cell(s) you want to 
name. 

Click the Name box in the 
Formula bar. 

Type the name you want for 
the cell or range. 

Tip: A cell or range name 
cannot include spaces. Use a 
period or underscore instead. 

Press Enter. 

Now, when you create a formula, use 
the name to reference the cell(s) 
instead. 

 

Use a Cell or Range Name in a Formula 
Click the cell where you want 
to add the formula. 

Type = followed by the formula 
you want to use. 

When you want to use a name, 
just type it. 

Click Enter when you’re 
finished. 

Tip: You can also click the 
Formulas tab on the Ribbon, 
click the Use in Formula 
button, and select a name from 
the list. 
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Go to a Name 
Cell and range names also make it easier to navigate a workbook. You can select a range name to jump to it 
in the workbook. 

Click the Name box list arrow. 

A list of all the named ranges in 
the workbook appears. 

Select the name you want to 
go to. 

Excel takes you to your named cell or 
cell range. 

 

 

 

 

 

Edit and Delete Cell or Range Names 
When you need to change or remove a named range, use the Name Manager. 

Click the Formulas tab. 

Click the Name Manager 
button. 
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Select the name you want to 
edit or delete. 

Click Edit or Delete. 

• Use Edit to change the name 
or update which cell or 
range the name refers to. 

• Use Delete if you no longer 
need the named cell or 
range. 

Click Close when you’re 
finished. 
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Insert Functions 

Excel has over 450 functions you can use to perform just about any kind of calculation. If you're having 
trouble finding the right function, the Insert Function command lets you search for the function you want. It 
also guides you through inserting the arguments, which is helpful for complex functions. 

Click the cell where you want 
to add a formula. 

Click the Insert Function 
button. 

Search for a function using one 
of these methods: 

• Type a few keywords that 
describe the function you 
want and click Go. 

• Select a category from the 
list arrow menu. 

Select the desired function. 

Click OK. 

The Function Arguments dialog 
box appears. Here you need to 
specify the arguments for the 
function you selected. In Excel, 
an argument can be a range of 
data, a specified output, or 
other parameters. 

If you're ever confused about 
what an argument is, just 
check the description down 
here. 

Enter the formula arguments. 

Click OK.  

The dialog box closes and Excel 
displays the results of the inserted 
formula. 

  



66  

CONCAT Function 

The concatenate function is used to combine text from multiple cells into a single cell. It can be a very 
helpful tool if you don’t want to manually manipulate existing Excel data. 

Concatenate Text 
Click where you want to insert 
the formula. 

Click the Formulas tab. 

Click the Text Function button. 

Select CONCAT. 

The concatenate function 
combines text exactly as it 
appears in a cell. If you want to 
add spaces or punctuation, you 
do so by putting the value you 
want to add in quotes (“ “) in a 
separate text field in the 
Function Arguments dialog 
box. 

Specify the text and any 
additional characters you want 
to join. 

The formula result appears at 
the lower-left corner of the 
dialog box. Verify it’s correct 
before completing the formula. 

Click OK. 

The concatenate function looks 
at the values in the arguments 
and combines the specified 
text into one cell. 
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PMT Function 

Financial functions let you calculate things like interest, payments, and future values. 

One of the most useful financial functions, the PMT function, calculates the payment for a loan based on 
periodic payments and a constant interest rate. For example, if you are taking out a $10,000 car loan at 8% 
interest and know that the loan would have to be paid off in four years, you could use the PMT function to 
calculate that the monthly payments for such a loan would be $244.13. 

PMT Function 
Select the cell where you want 
to add the result of the 
payment function. 

Click the Insert Function 
button. 

Tip: The Insert Function 
feature helps you select, enter, 
and edit worksheet functions. 

Select Financial from the list of 
function categories. 

Select the PMT function. 

A description appears below 
the list describing what the 
PMT function calculates. 

Click OK. 
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Fill in the function arguments. 

Pay attention to the argument 
notes below the argument 
fields. These give details about 
what to enter for the 
argument. 

The arguments in bold are 
required; the others are 
optional. 

Shortcut: Instead of typing 
argument values, click in an 
argument field, then select a 
cell or cell range in the 
worksheet. 

Click OK when you’re finished. 

The payment function calculates all the 
arguments and puts the result in the 
selected cell. 
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Display Formulas 

You can better understand what’s going on in your workbooks by showing and highlighting all the formulas 
in a sheet. 

Show/Hide Formulas 
By default, Excel displays the results of formulas in the worksheet instead of showing the actual formulas. 
However, you can choose to have Excel display the formulas so you can see how they’re put together. 

Click the Formulas tab. 

Click the Show Formulas 
button. 

Formulas are displayed in the 
worksheet and the columns 
widen to accommodate the 
formulas, if necessary. 

Tip: If you display formulas and 
then select a cell that contains 
a formula, colored lines appear 
around cells that are 
referenced by the formula. 

Click the Show Formulas 
button again to hide the 
formulas. 

Formulas are no longer displayed and 
the columns return to their original 
sizes. 
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Highlight Formulas 
If you don’t want to see the actual formulas, but want to know which cells contain them, highlight cells with 
formulas instead. 

Click the Home tab. 

Click the Find & Select button. 

Select Formulas. 

Any cells that contain a formula are 
highlighted; however, this doesn’t 
change the cell formatting. When you 
click any other cell in the worksheet, 
the highlighted cells are unselected. 
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Date Formulas 

You can use dates and time in your formulas just like any other value. For example, if cell A1 contained the 
entry 5/1/19 you could use the formula =A1+100 to calculate the date 100 days later, which is 8/9/19. 

One very important thing to know about working with date and time functions: while Excel can display dates 
and times using just about any format, it stores dates as chronological numbers called serial values. So, 
when you think of dates as months, days, and years, such as May 1, 2019, Excel thinks of dates in terms of 
serial numbers, such as 36281. 

Since the date and time formulas often return serial number values, you should format any cells with date or 
time formulas with date and time formats that you can easily understand. 

Common Date Functions 
This table lists some of the date and time functions available in Excel. 

Function Name Function What the Function Does 

Date =DATE(year, month, day) Enters a date in the cell. 
Example: DATE(2019,5,1) equals May 1, 2019. 

Today 
=TODAY( ) A special version of the DATE function. The DATE 

function returns the value of any date; the TODAY 
function returns the value of the current date. 

Time 
=TIME(hour, minute, second) Enters a time in the cell. Uses a 24-hour (military) 

time system. 
Example: TIME(14,30,0) equals 2:30 PM. 

Now 
=NOW( ) A special version of the TIME function. The TIME 

function returns the value of any time; the NOW 
function returns the value of the current time. 

Year 

=YEAR(serial_number, 
return_type) 

Returns a value of the year for a specific date. The 
serial_number argument is a date value (or 
reference to one). 
Example: YEAR("3/15/2019") equals 2019. 

Month 

=MONTH(serial_number, 
return_type) 

Returns a value of the month for a specific date. 
The serial_number argument is a date value (or 
reference to one). 
Example: MONTH("3/15/2019") equals 3. 

Day 

=DAY(serial_number, 
return_type) 

Returns a value of the day for a specific date. The 
serial_number argument is a date value (or 
reference to one). 
Example: DAY("3/15/2019") equals 15. 
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TODAY() Function 
If you need to calculate values based on dates, a very helpful function is TODAY, which returns today’s date. 

Select the cell where you want 
to add the TODAY() function. 

Click the Formulas tab on the 
Ribbon. 

Click the Date & Time button. 

Select Today. 

Click OK. 

Tip: You can also insert the 
function by typing =TODAY() in 
the cell. 

Excel adds today’s date. 
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Date Calculations in Formulas 
Referencing cells with a date calculation in a formula is often no different than referencing cells with 
numbers—you can include date values in basic formulas. 

Select the cell where you want 
to calculate a date formula. 

Press = and enter the formula, 
referencing the cells that 
contain a date formula. 

Click the Enter button. 

 





 © 2022 CustomGuide, Inc. 75 

Manage Data 
In this module, learn how to quickly manipulate the 
display of your data using built-in styles that best suit 
your data set. View meaningful hierarchies and 
groupings using Outline and Subtotal to make your 
data easier to consume. 

If your spreadsheet is shared with others, you can use 
data validation to guide or control what data is 
entered. Standardization is key to maintaining data 
integrity so this an important feature. 

You may need to export or import data to or from 
formats other than an Excel file to accommodate 
databases or web pages. This module will show you 
how. 

Objectives 
Quick Analysis 

Outline and Subtotal 

Data Validation 

Flash Fill 

Import and Export Data 
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Quick Analysis 

The Quick Analysis function helps you quickly format your data into a chart, table, summary formula, 
sparkline, or highlighted figures with just a few simple steps. 

Use the Quick Analysis Button 
Select the cell range you want 
to summarize. 

Tip: Be careful when selecting 
your data. The Quick Analysis 
button will not appear when 
using the Ctrl key to make 
multiple selections. 

Click the Quick Analysis 
button. 

Select the type of analysis tools 
you want to use. 

• Formatting: Highlight data 
using conditional 
formatting. 

• Charts: Chart the selected 
data. 

• Totals: Create common 
summary formulas. 

• Tables: Summarize data in a 
table or PivotTable. 

• Sparklines: Mini charts 
placed in single cells. 
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Outline and Subtotal 

Many spreadsheets are created in a hierarchical style. For example, a worksheet might contain a column for 
a person or company, followed by a column with sales data. By outlining your worksheets, you make them 
easier to understand and read. Instead of sifting through irrelevant information, you can collapse an outline 
to display each group’s bottom line. There are several ways to outline a workbook: 

• Using the Auto Outline Feature: The Auto Outline command automatically outlines a selected range 
of cells or the entire worksheet, based on formulas and the direction of references. 

• Grouping Data: You can group rows and columns manually by selecting them. 

• Using the Subtotals Feature: The Subtotals command calculates subtotal values for the labeled 
columns you select. Excel automatically inserts and labels the total rows and outlines the list. 

• Using the Consolidate Feature: You can consolidate several sheets using the Consolidate feature.  

This lesson explains how to turn on the subtotals feature and then use the outline options to simplify the 
data view. 

Add Subtotals 
Before you turn on subtotals, there are a few preliminary steps that must be completed. First, make sure 
your data is arranged into labeled columns. The data in each column must also be of the same type and it 
needs to be sorted based on the column you want to group the subtotals by. 

Click in the column you want to 
subtotal. 

Click Sort & Filter on the Home 
tab. 

Select a sort option. 

Once the data is sorted, the 
subtotal can be applied. 
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Click the Data tab. 

Click Subtotal. 

Click the At each change in list 
arrow. 

Select the column you want to 
subtotal. 

This command specifies what it 
is that you want to subtotal. 
For example, if you have a list 
of people, the company they 
work for, and the amounts of 
their sales, and you want to 
subtotal the list by the 
company name, you would 
select the column that contains 
the company name. 

Click the Use function list 
arrow. 

Usually you create subtotals 
with the SUM function, but you 
can also create subtotals using 
functions such as COUNT, 
AVERAGE, MAX, and MIN. 

Select the function you want 
the subtotal to perform. 
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In the Add subtotal to box, 
select the check box next to 
each column that has values 
you want to subtotal. 

Tip: To add more subtotals, 
repeat the steps but clear the 
Replace current subtotals 
check box so you don’t 
overwrite the existing 
subtotals. 

Click OK. 
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Outline Options 
Once subtotals are applied, the outline levels appear at the left. The outline allows you to collapse the 
detailed rows or columns and view only the subtotals. 

Select an outline level. 

Expand a category to view 
additional details. 

 

 

 

 

 

 

 

 

 

 

Remove Outlines and Subtotals 
Click the Data tab. 

Click the Subtotal button. 

Click Remove All. 

The outline is cleared from the 
worksheet. 
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Data Validation 

You can help users enter accurate and appropriate information into your worksheets with Excel’s Data 
Validation feature. Data validation restricts the type of information that can be entered in a cell and can 
provide the user with instructions for entering information in a cell. 

Create a Validation Rule 
Select the cells you want to 
validate. 

Click the Data tab. 

Click the Data Validation 
button. 

Click the Allow list arrow. 

Select the type of data you 
want to allow. 

• Any value: No validation 
criteria applied.  

• Whole number: Allows a 
whole number between the 
minimum and maximum 
limits set. 

• Decimal: Allows a decimal or 
a percent entered as a 
decimal between the set 
limits. 

• List: Allows a value from a 
list of choices. A list arrow 
appears in the cell, and 
users can choose from the 
list. 

• Date: Allows a date within 
set limits. 

• Time: Allows a time within 
set limits. 

• Text length: Allows text 
containing a certain number 
of characters. 

• Custom: Allows a formula to 
be entered to calculate what 
is allowed in the cell. 
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Specify the data validation 
rules. 

Tip: The validation options will 
vary depending on the option 
selected in the Allow field. 

Click OK. 

The data validation is set for the 
selected cell(s). When a user tries to 
enter data that is not valid, Excel will 
prevent the entry and display a 
message about the cell being 
restricted. 

Tip: To find validated data in a 
worksheet, click the Find & Select 
button in the Editing group on the 
Home tab and select Data Validation. 
The validated cells are highlighted. 
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Add Input and Error Messages 
Prevent data validation issues by setting up Excel to display a message whenever a cell or range of cells is 
selected. These messages are useful when other people will be entering data in your worksheet. An error 
message can be configured to appear when data is entered that does not match a data validation rule. 

Select the cells where you 
want an input message to 
appear. 

Click the Data tab. 

Click the Data Validation 
button. 

Click the Input Message tab. 

Enter an input message. 

Click the Error Alert tab. 

Select an error alert style. 

• Stop: Prevents users from 
adding invalid data in a cell. 

• Warning: Warns that the 
data entered is invalid, but 
users can click Yes to accept 
the invalid entry, No to edit 
it, or Cancel to remove it. 

• Information: Informs users 
that the data entered is 
invalid, but users can click 
OK to accept the invalid 
entry or Cancel to remove it. 
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Enter an error alert message. 

Click OK. 

Select a cell with an input 
message. 

Now when a cell in the range is 
selected, the title and message display. 
If you enter an invalid value, a custom 
error message appears. 
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Flash Fill 

Flash Fill is a feature in Excel that automatically enters values in a column when a pattern is recognized. It 
can save a lot of time when manually entering a long list of data, like consecutive values or dates. 

Use Flash Fill 
Click the cell to the right of the 
data you want to work with. 

Type the first value you want 
to extract in the new column 
and press Enter. 

Begin typing the second value 
below the first. 

When you start typing in the 
second value, Excel recognizes 
the pattern and predicts the 
values for the rest of the 
column. 

Tip: If the pattern isn’t 
recognized when the second 
cell is populated, complete the 
data for the second cell and 
move to the third. The pattern 
should be recognized when 
you begin entering data in the 
third consecutive cell. 

Press Enter to accept the 
suggested Flash Fill values. 

Excel populates the rest of the column 
following the same pattern of data. 
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Import and Export Data 

Excel can import and export many different file types aside from the standard .xslx format. If your data is 
shared between other programs, like a database, you may need to save data as a different file type or bring 
in files of a different file type. 

Export Data 
When you have data that needs to be transferred to another system, export it from Excel in a format that 
can be interpreted by other programs, such as a text or CSV file. 

Click the File tab. 

At the left, click Export. 

Click Change File Type. 

Under Other File Types, select 
a file type. 

• Text (Tab delimited): The 
cell data will be separated 
by a tab. 

• CSV (Comma delimited): 
The cell data will be 
separated by a comma. 

• Formatted Text (space 
delimited): The cell data will 
be separated by a space. 

• Save as Another File Type: 
Select a different file type 
when the Save As dialog box 
appears. 

Tip: The file type you select will 
depend on what type of file is 
required by the program that 
will consume the exported 
data. 

Click Save As. 
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Specify where you want to 
save the file. 

Click Save. 

A dialog box appears stating 
that some of the workbook 
features may be lost. 

Click Yes. 

 

 

 

 

 

Import Data 
Excel can import data from external data sources including other files, databases, or web pages. 

Click the Data tab on the 
Ribbon. 

Click the Get Data button. 

Tip: Some data sources may 
require special security access, 
and the connection process 
can often be very complex. 
Enlist the help of your 
organization’s technical 
support staff for assistance. 

Select From File. 

Select From Text/CSV. 

If you have data to import from 
Access, the web, or another 
source, select one of those 
options in the Get External Data 
group instead. 
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Select the file you want to 
import. 

Click Import. 

If, while importing external 
data, a security notice appears 
saying that it is connecting to 
an external source that may 
not be safe, click OK. 

Verify the preview looks 
correct. 

Because we've specified the 
data is separated by commas, 
the delimiter is already set. If 
you need to change it, it can be 
done from this menu. 

Click Load. 
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Tables 
You can create tables from Excel data ranges. There are 
several benefits of working with your data in a table, 
including automatic filtering controls and built-in table 
formatting options. When rows and columns are added 
or removed, the table and styles automatically adjust 
accordingly. 

You can also add slicers to your worksheet to make 
filtering on multiple conditions faster and more 
transparent to your audience. Slicers allow you to set 
specific filtering criteria for multiple columns without 
needing to use the column filter drop-down lists. While 
slicers are commonly used with PivotTables, they’re 
also available and useful when working with tables. 

Objectives 
Insert a Table 

Sort Data 

Filter Data 

Add Rows and Columns  

Table Styles 

Remove Duplicates 

Slicers 

Structured References 
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Insert a Table 

By turning an Excel range into a table, you can work with the table data independently from the rest of the 
worksheet, and filter buttons appear automatically on the column headers, allowing you to filter and sort 
columns even faster. You can also add total rows and quickly apply table formatting. 

Create a Table 
If you already have an organized range of data, you can turn it into a table. Before turning a range of data 
into a table, remove blank rows and columns, and make sure that a single column doesn’t have different 
types of data within it. 

Click a cell in the range you 
want to convert to a table. 

Click the Format as Table 
button on the Home tab. 

Select the table style you want 
to use. 

Tip: You can also click the 
Insert tab on the Ribbon and 
click the Table button in the 
Tables group. 

Verify the data range includes 
all the cells you want to include 
in the table. 

Make sure to specify whether 
the table has a header row. If it 
doesn’t, Excel will add a header 
row above the table data. 

Click OK. 

The table is created. Filters are added 
to each column and the table is 
automatically formatted. Under Table 
Tools on the Ribbon, the Design tab 
appears. 
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Apply a Table Style 
You can change the appearance of a table at any time by applying a preset table formatting style. 

Click a cell in the table. 

Click the Design tab. 

Click the Quick Styles button 
from the Table Style group. 

The table styles gallery 
appears. Here you can select 
styles from the Light, Medium, 
or Dark categories. You may 
need to scroll down the list to 
see the Dark category. 

Select a style. 

 

 

 

Convert to a Range 
If a table is no longer needed, turn it back into a normal range of data. 

Click a cell in the table. 

Click the Design tab. 

Click the Convert to Range 
button. 

Click Yes. 

Shortcut: Right-click a cell in 
the table and select Table, 
then Convert to Range from 
the contextual menu. 

The table converts back to a normal 
range of cells, but the table formatting 
is still applied. 

Tip: If you don’t want the table 
formatting to be applied, click the 
Quick Styles button on the Design tab 
and select None before converting the 
table to a range. 
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Sort Data 

In Excel, you can take tables or ranges of data and sort them into different orders. For example, you can sort 
text alphabetically; numbers by size; dates and times chronologically; cells or fonts by color or icon; or you 
can create a custom sort. Usually you sort by column, but you can also sort by row. 

Sort by One Column 
Select a cell in the column you 
want to sort. 

Click the Sort & Filter button 
on the Home tab. 

Select a sort order. 

• Sort A to Z: Sorts the 
column in ascending order. 

• Sort Z to A: Sorts the 
column in descending order. 

• Custom Sort: Allows you to 
specify custom criteria, such 
as multi-level data sorting.  

Tip: You can also right-click the 
cell and select Sort. 

Sort by Multiple Columns 
If you want to sort by more than one column, you need to use a custom sort. For example, you can sort first 
by the last name column, then by first name. That way, all the Andersons will be listed before the Bakers, 
and Andy Anderson will come before Bill Anderson. 

Click the Sort & Filter button 
on the Home tab. 

Select Custom Sort. 

The Sort dialog box appears. 
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Select the first column you 
want to sort by. 

Tip: To sort by cell or font 
color, or by icon, click the Sort 
On list arrow and select an 
option. 

Select a sort order.  

The options for the Order 
change depending on what you 
choose for the Sort by variable. 

To sort by an additional 
column, click the Add Level 
button. 

Select the next column you 
want to sort by.  

Select a sort order.  

Repeat these steps as 
necessary to sort by additional 
columns. 

Click OK. 
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Filter Data 

When you create a table, a filter button that looks like a list arrow is added to the header of each column in 
the table. You can use this arrow to filter the table columns; they remain available when you scroll down the 
list. You can filter by values such as text, numbers, or dates. 

Filter 
Click the filter arrow for the 
column you want to filter. 

A list appears, displaying 
several options for sorting or 
filtering the table data. A check 
box will appear for each of the 
unique data entries for the 
selected field. 

Select the check box(es) of the 
filter criteria you want to use. 

Tip: You can also click in the 
Search field and type the 
criteria by which you want to 
filter, or click Text Filters to 
apply advanced filtering 
criteria. 

Click OK. 

Clear a Filter 
Click the filter arrow for the 
column with a filter you want 
to clear. 

Select Clear Filter From 
“Column Name.” 

Tip: You can also click the Filter 
button on the Data tab to 
toggle the filter off. 

The filter is removed and all the data in 
that column is visible again. 
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Add Rows and Columns  

Even after a table is created, you can add additional rows and columns. Whether you add new cells within 
the current range or adjacent to the table, they will automatically be formatted to match the current table 
style. 

Insert a Row or Column Adjacent to the Table 
Click in a blank cell next to the 
table. 

Type a cell value. 

Click anywhere outside the cell 
or press the Enter key to add 
the value. 

The new row or column is added to the 
table and the table formatting is 
applied. 

Tip: When a formula is entered in a 
blank column of a table, the formula 
automatically fills the rest of the 
column, without using the AutoFill 
feature. If rows are added to the 
column, the formula appears in those 
rows as well. 
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Insert a Row or Column within a Table 
Select a cell in the table row or 
column next to where you 
want to add the row or 
column. 

Tip: Insert options aren’t 
available if you select a column 
header. 

Click the Insert list arrow on 
the Home tab. 

Select an insert table option.  

• Insert Table Rows Above: 
Inserts a new row above the 
select cell. 

• Insert Table Columns to the 
Left: Inserts a new column 
to the left of the selected 
cell. 

Shortcut: Right-click a row or 
column next to where you want 
to add data, point to Insert in 
the menu, and select an 
insertion option. 

Delete Rows and Columns 
You can also remove unwanted table rows and columns by deleting them.  

Select a cell in the row or 
column you want to delete. 

Click the Delete list arrow. 

Select Delete Table Rows or 
Delete Table Columns. 

Shortcut: Right-click the row or 
column you want to delete, 
point to Delete in the menu, 
and select Table Columns or 
Table Rows. 

The selected row(s) or column(s) and 
all the data in them are deleted. 
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Table Styles 

Besides applying table styles, you can format individual table style elements. 

Table Style Options 
Click any cell in the table. 

Click the Design tab. 

The formatting options 
available in the Table Style 
Options group include: 

• Header Row: Toggles the 
table’s header row on and 
off. 

• Total Row: Adds a total row 
to the bottom of the table. 
This option doesn’t just 
change formatting, but also 
allows you to calculate 
values in the total row. 

• First/Last Column: Displays 
special formatting for the 
first or last columns in the 
table. 

• Banded Rows/Columns: 
Displays odd and even rows 
and columns differently for 
easier readability. 

Select the option(s) you want to 
apply in the Table Style Options 
group. 
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Remove Duplicates 

If there are duplicate rows of identical data in your table, Excel can find and remove the duplicate rows for 
you. You can also remove duplicates from cell ranges, not just tables. In that case, you need to select the 
entire cell range you want to examine. 

Remove Duplicate Values 
Select a cell in the table. 

Click the Data tab. 

Click the Remove Duplicates 
button. 

All columns are selected by 
default, but it’s possible to 
select/deselect individual 
columns in the Columns list. 
You can also use the Select All 
and Unselect All buttons to 
select columns. 

Select the columns you want to 
check for duplicates.  

Click OK. 

The dialog box displays the 
number of duplicates that 
were removed and how many 
values remain. 

Tip: Removing duplicate values 
actually deletes the duplicate 
data, so you may want to copy 
the data to another worksheet 
or workbook first, just in case. 

Click OK. 
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Slicers 

Slicers are a feature in Excel that provide an easy way to filter table data. They allow you to filter and re-
filter your data quickly so it’s easy to find the exact information you need. Slicers work well when used with 
both tables and PivotTables. 

Insert a Slicer 
Click any cell in the table. 

Click the Design tab. 

Click the Insert Slicer button. 

Tip: You can also click the 
Insert tab, then click Slicer. 

The Insert Slicers dialog box 
appears. All the column 
headings in the table are listed 
here. 

Select the columns you want to 
use as slicers. 

A separate slicer will be 
created for each column that’s 
selected. 

Click OK. 

The slicers appear in the worksheet. 
You can now move or resize them as 
needed. 
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Filter with a Slicer 
After a slicer is created, it appears on the worksheet alongside the table. The slicers will be layered on top of 
one another if there is more than one, but they can easily be repositioned. 

Select the values you want to 
include in the filter. 

Hold down the Ctrl key to 
select multiple filters. 

The table is filtered to show only the 
selected value(s). 

Tip: While holding down the Ctrl key, 
simply click the value again to stop 
filtering the selected data. 

 

 

 

 

Clear and Remove a Slicer 
Before you delete a slicer from a worksheet, make sure you clear it. Deleting a slicer doesn’t clear the filter.  

Click the Clear Filter button. 

All the filters are cleared, but 
the Slicer remains on the 
worksheet. 

Right-click the slicer. 

Select Remove “Filter name”. 

Shortcut: Click the slicer and 
press the Delete key. 
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Structured References 

Structured references allow you to easily work with cell references and formulas in a table. For example, 
instead of using a cell range reference such as F2:F52 in a formula, you can refer to the cell range as Sales 
(the table column name). They make it easy to see, at a glance, what the formula is calculating.  

When you create a formula using structured references, you can use several different elements in place of 
the regular arguments. These include the table name, column header names, or special items that refer to 
areas of the table, such as a total row. 

Name a Table 
Structured references work best if the table is assigned a meaningful name. 

Select a cell in the table. 

Click the Design tab. 

Click in the Table Name field. 

Type a table name. 

Press Enter on your keyboard. 
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Enter a Structured Reference 
When using structured references, the formula will include the table name as well as the name of the row or 
column you want to calculate. 

Select the cell where you want 
to add the structured 
reference. 

Type the formula using table 
names instead of cell 
references. 

Click the Enter button or press 
Enter on your keyboard. 
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Intermediate Formatting 
Conditional formatting is a flexible and powerful 
feature. It allows you to highlight cells if they meet a 
specified condition. You can use it to quickly identify 
values above or below certain points, duplicates, or 
matching text. 

In this module, you will also learn how to format your 
worksheet using cell styles, which is useful if you want 
to add special effects to headings and total rows or if 
you need to use specific fonts and colors to meet your 
organization’s brand standards. Applying themes 
makes it even easier to have a consistent look and feel 
from one worksheet to another. 

Objectives 
Apply and Manage Conditional Formatting 

Apply and Remove Cell Styles 

Create and Modify Cell Styles 

Find and Replace Formatting 

Apply a Theme 
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Apply and Manage Conditional Formatting 

Conditional formatting applies formats to cells only if a specified condition is true. For example, use 
conditional formatting to change cells with a sales value over $50,000 to have red, bold font. If the value of 
the cell changes and no longer meets the specified condition, the cell returns to its original formatting. 

Apply Conditional Formatting 
Select the cells you want to 
change. 

Click the Conditional 
Formatting button from the 
Home tab. 

Select a conditional formatting 
category. 

• Highlight Cells Rules: Focus 
on general analysis. Preset 
conditions include: Greater 
Than; Less Than; Between; 
Equal To; Text That 
Contains; Date Occurring; 
Duplicate Values. 

• Top/Bottom Rules: Focus on 
the high and low values in 
the worksheet. Preset 
conditions include: Top 10 
Items; Top 10%; Bottom 10 
Items; Bottom 10%; Above 
Average; Below Average. 

• Data Bars: Colored bars that 
appear in the cells. The 
longer the bar, the higher 
the value in that cell.  

• Color Scales: Cells are 
shaded different color 
gradients depending on the 
relative value of each cell 
compared to other cells in 
the range 

• Icon Sets: Different shaped 
or colored icons appear in 
cells, based on each cell’s 
value.  

Select a conditional formatting 
rule. 
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Specify the formatting to use 
for items that meet the 
conditional formatting criteria. 

Tip: The options you see in the 
dialog box will vary depending 
on the type of rule you 
selected. 

Click OK. 

Only the cells that meet the criteria are 
formatted. 

 

 

 
 

Manage Conditional Formatting Rules 
You can manage all aspects of conditional formatting—creating, editing, and deleting rules—in one place 
using the Rules Manager. 

Select the cell range with the 
conditional formatting you 
want to manage. 

Click the Conditional 
Formatting button on the 
Home tab. 

Select Manage Rules. 
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The Conditional Formatting 
Rules Manager dialog box 
appears. The rules applied to 
the selected cells appear in the 
dialog box. 

Use these buttons to manage 
the rules: 

• New Rule: Create a brand 
new conditional formatting 
rule. 

• Edit Rule: Edit the selected 
formatting rule. 

• Delete Rule: Delete the 
selected rule from the 
worksheet. 

Manage the formatting rules.  

Click OK when you are finished. 

 

Remove Conditional Formatting 
The Clear Rules command helps you remove conditional formatting rules from your worksheet. 

Click the Conditional 
Formatting button on the 
Home tab. 

Select Clear Rules. 

Select a Clear Rules option: 

• Clear Rules from Selected 
Cells: Clears only the 
conditional formatting rules 
for the selected cell range.  

• Clear Rules from Entire 
Sheet: Clears all the 
conditional formatting rules 
in the worksheet. 
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Apply and Remove Cell Styles 

Styles contain preset font formatting, cell shading, numbering, borders, and other formatting options that 
can be applied to a cell or cell range all at once. This is a convenient and easy way to quickly apply complex 
formatting. 

Apply a Cell Style 
Select the cell(s) you want to 
format. 

Click the Cell Styles button on 
the Home tab. 

Tip: Hover your mouse over a 
style to preview how it will 
look before selecting it. 

Select a cell style. 

The style is applied to the selected cell 
or cell range. 

 

 

 

Remove a Cell Style 
If you decide you no longer need the style applied to the cells, you can remove it. 

Select the cells that have the 
style applied. 

Click the Cell Styles button on 
the Home tab. 

Select Normal. 
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Create and Modify Cell Styles 

If you find that you keep applying the same formatting over and over, create a style with that formatting so 
you can apply those formatting settings with one click. 

Create a New Style 
The easiest way to create a style is to do so from a cell that already has the formatting you want to capture. 

Select the cell that has the 
formatting you want to use for 
the new style. 

Click the Cell Styles button on 
the Home tab. 

Select New Cell Style. 

The Style dialog box opens and 
the formatting from the 
selected cell is captured. 

Enter a name in the Style name 
field.  

Click OK. 

The style is now saved and can be used 
in any Excel worksheet. 

Tip: Cell styles are associated with the 
theme that is being used for the 
workbook. If you switch to a new 
theme, the cell styles will update to 
match it. 
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Modify a Style 
If you decide you need to change an existing style, you can easily make modifications. Any updates you 
make will automatically be reflected in any cells that have the style applied.  

Click the Cell Styles button. 

Right-click the cell style you 
want to modify. 

Select Modify. 

Tip: To duplicate a style before 
making changes, select 
Duplicate from the menu 
instead. 

Click the Format button. 
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Select the formatting options 
you want to use. 

Click OK. 

Click OK again. 

The style is updated and any cells with 
the style applied are automatically 
updated. 

Tip: To remove a cell style from all cells 
and delete the cell style itself, click the 
Cell Styles button on the Home tab. 
Then right-click the style and select 
Delete. 
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Find and Replace Formatting 

Excel’s Find and Replace features can find and/or replace formatting in addition to text and information. Use 
the Find and Replace Formatting option when you want to change all instances of a particular formatting 
choice at once. 

Using Find and Replace Formatting 
Click the Find & Select button 
on the Home tab. 

Select Replace. 

Shortcut: Press Ctrl + H to 
open the Find and Replace 
dialog box. 

Click the Options button. 

Click the Find what: Format 
button. 
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The Find Format dialog box 
opens. Here you can select any 
type of formatting you want to 
look for in the workbook. 

Select the formatting you want 
to find. 

Click OK. 

Click the Replace with: Format 
button. 
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Select the new formatting 
options you want to use. 

Click OK. 

Once the formatting options 
are set, you’re ready to begin 
finding and replacing the 
formatting. 

Select the Find or Replace 
option you want. 

• Click Find Next or Find All to 
locate the formatting you 
want replace before 
replacing it. 

• Click Replace to change cells 
one at a time. 

• Click Replace All to replace 
every instance of the 
formatting at once. 

When you choose to replace all 
instances of the formatting, 
the dialog box lets you know 
how many replacements were 
made. Click OK. 

Click Close. 
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Apply a Theme 

Document themes coordinate the look of a worksheet with theme colors, theme fonts, and theme effects. 

• Theme Colors: A set of 8 coordinated colors used to format text and objects in the worksheet. 

• Theme Fonts: A set of coordinated heading and body font types. 

• Theme Effects: A set of coordinated formatting properties for shapes and objects in the worksheet. 

Apply a Workbook Theme 
Themes help give your worksheet a consistent look and feel. 

Click the Page Layout tab. 

Click the Themes button. 

Small thumbnails appear 
showing what each theme 
looks like. 

Select a theme. 

The formatting associated with the 
selected document theme is applied to 
the workbook. 
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Customize a Document Theme 
You are not bound to keep the colors, fonts, or effects that are assigned to a document theme. You may mix 
and match theme colors, theme fonts, and theme effects. 

Click the Page Layout tab on 
the Ribbon. 

Click the Theme Colors, Theme 
Fonts, or Theme Effects button 
and select the set of colors, 
fonts, or effects you want to 
use. 
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Collaborate with Excel 
There are several options for sharing workbooks that 
make it easy for others to review and provide 
feedback. You can add comments directly to a cell so 
your note has context. If you track changes in your 
document, any adjustments made in the review 
process will be transparent and can be accepted or 
rejected. 

This module also covers various methods for protecting 
your workbook. You can add protection as discretely as 
locking a cell from edits, or as broadly as requiring a 
password to open a workbook. 

Objectives 
Cell Comments 

Share Workbooks 

Co-author Workbooks 

Version History 

Protect a Worksheet 

Protect Workbook Structure 

Password Protection 
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Cell Comments 

Sometimes you may need to add notes to document complicated formulas, call out questionable values, or 
even to leave a comment for another user. Excel’s cell comments command helps you document your 
worksheets and make them easier to understand. Think of cell comments as sticky notes that you can attach 
to any cell. Cell comments appear whenever you point at the cell they’re attached to. 

Add a Comment 
Click the cell where you want 
to add the comment. 

Click the Review tab. 

Click the New Comment 
button. 

Shortcut: Right-click a cell and 
select New Comment. 

Type the comment you want. 

Click the Post button. 

Click anywhere outside the 
comment. 

The comment disappears, but a red 
triangle appears in the corner of the 
cell to show that it has a comment. 
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View a Comment 
Point to a cell with a comment 
icon. 

Tip: To display a comment all the time, 
click the cell with the comment, then 
click the Review tab on the Ribbon and 
click the Show/Hide Comments button 
in the Comments group. 
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Edit a Comment 
Click the cell that contains the 
comment you want to edit. 

Click the Edit button in the 
comment. 

Make the changes and then 
click Save. 

Shortcut: Right-click a cell with 
a comment and select Edit 
Comment. 

The comment box reappears, ready for 
editing. 
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Delete a Comment 
Click the cell that contains the 
comment you want to delete. 

Click the Review tab. 

Click the Delete button. 

Shortcut: Right-click a cell with 
a comment and select Delete 
Comment. 

The comment is removed from the cell. 
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Share Workbooks 

If you need to share a workbook with others, you can send them an invitation to view it online. You can also 
share workbooks by emailing them as an attachment, although this sends them a copy of the workbook and 
not the original. 

Invite People to Collaborate 
When you share a workbook from 
Excel, you're giving others access to the 
exact same file. This lets you and 
others view and even edit the same 
workbook without having to keep track 
of multiple copies. 

Save your workbook to your 
OneDrive or SharePoint. 

Workbooks must be saved to 
either Microsoft OneDrive or 
SharePoint before you can 
share them with others. 

Click the Share button. 

The Share pane opens, where 
you can invite others to view 
and edit this file. 

Enter the email address of each 
person you want to share with. 

Click the Permissions list 
arrow. 

This lets you decide whether 
the people you invite can make 
changes to the workbook, or 
just view it as a read-only 
document. 

Select a permission level for 
the file. 

Click Apply. 
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Include a message (optional). 

Click Send. 

Tip: If you wanted to just send 
a link to people at will, you 
could do so by clicking Copy 
Link or Outlook. 

The people you shared the workbook 
with will appear in the Share pane. 
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Co-author Workbooks 

You can work on a file in Excel at the same time as others by using Office's Co-author feature. 

Simultaneously Edit 
Make sure the file is saved to an online location like SharePoint or OneDrive, and that you’ve shared it with 
people who need to make edits. 

Click a user’s picture or initials 
in the ribbon to see what they 
are editing. 

• Cells being edited by others 
appear with a colored 
border or shading. 

• Changes are automatically 
synced. 

Click the Save button to force a 
sync and display new changes. 

All of the changes are immediately 
synced to the workbook. 
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Version History 

Nothing is more frustrating than when a program locks up—and stops responding—for no apparent reason. 
You can protect your work from these events by using the AutoRecover feature to periodically save a 
temporary copy of the project you're working on. 

Modify Recovery Settings 
When the AutoRecover feature is enabled, a backup copy of the workbook is saved every 10 minutes (its 
default setting). However, you can change the AutoRecover save interval to occur more or less frequently. 

Click the File tab. 

Click Options. 

The Excel Options dialog box 
appears. 
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Click Save. 

Click in the Minutes field. 

Enter a value for how 
frequently you'd like to save 
AutoRecover information. 

Click OK. 

Even with Excel’s document recovery 
features, the best way to ensure that 
you don’t lose much information if 
your computer freezes up is to save 
your work regularly. 

 
 
 
 
 

Recover Unsaved Workbook Versions 
If AutoRecover is enabled in Excel, you don’t have to do anything to make it work. Any available unsaved 
versions can be found in the Backstage view. 

Click the File tab. 

If needed, scroll to the Version 
history section. 

Select an autosaved version of 
the file in the list of recovered 
files. 

Tip: If the version you need to 
recover isn’t in the recent list, 
click the Manage Workbook 
button and select Recover 
Unsaved Workbooks to see if 
the version you need is saved 
there. 

The previous version of the file 
opens. At the top, you see a 
notification that this is an 
AutoSaved version. 

The file is restored to the previous 
version. 
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Online Version History 
If this is a file that’s saved online, there’s another way to view version history. 

Click the Title Bar button. 

Select Version History. 

Here you see all the changes 
that have been made to the 
file, either by you or anyone 
the file is shared with. 

Click Open version for the file 
you want to restore. 
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Save an additional copy of the 
file or click the Restore button. 
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Protect a Worksheet 

Prevent unauthorized changes to data by protecting worksheets. In a protected worksheet, none of its 
contents can be changed. However, it’s possible to set up the worksheet so that only certain cells and 
elements can be changed after it's protected. 

Lock or Unlock Cells 
By default, cells are locked once a worksheet is protected. If there are cells that users should be able to 
change after a worksheet has been protected, make sure to unlock them before you protect the worksheet. 

Select the cells you want to 
unlock. 

Click the Format button on the 
Home tab. 

Select Format Cells. 

Click the Protection tab. 

Clear the Locked check box. 

Shortcut: You can also toggle 
the lock on and off by clicking 
the Format button and 
selecting Lock Cell. 

Locking and unlocking cells 
only takes effect once the 
sheet is protected. 

Click OK. 

The selected cells will now stay 
unlocked and editable by others after 
the sheet is protected. 
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Hide Formulas 
You can also prevent certain formulas from being displayed once the worksheet has been protected. 

Select the cells with a formula 
you want to hide. 

Click the Format button on the 
Home tab. 

Select Format Cells. 

Select the Hidden check box. 

Click OK. 

Remember, even if cells are locked and 
hidden, it doesn’t take effect until the 
worksheet is protected. 
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Protect a Worksheet 
Once you finish preparing the worksheet, it’s time to protect it. 

Click the Review tab. 

If necessary, expand the 
Protect group. 

Click the Protect Sheet button. 

Shortcut: You can protect or 
unprotect a worksheet by 
right-clicking the sheet tab and 
selecting Protect Sheet or 
Unprotect Sheet from the 
contextual menu. 

Select what you want to 
protect. 

A password isn’t necessary to 
protect the sheet; however, if 
one is not entered, anyone can 
unprotect it. 

Click OK. 
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Protect Workbook Structure 

You can secure a workbook’s structure against changes, such as sheets being added or deleted. You can also 
protect a workbook’s windows so that they are the same size and in the same position every time the 
workbook is opened. 

Protect Workbook Structure 
Click the Review tab. 

If necessary, expand the 
Protect group. 

Click the Protect Workbook 
button. 

Type a password, if desired. 

Click OK. 

Reenter the password. 

Click OK. 

The workbook is now protected. When 
you right-click the sheet tab, all the 
options for changing the structure are 
unavailable. 

  



 © 2022 CustomGuide, Inc. 133 

Turn Off Workbook Protection 
If you need to turn off workbook protection, you can do so at any time. 

Click the Review tab. 

If necessary, expand the 
Protect group. 

Click the Protect Workbook 
button. 

Enter the password. 

Click OK. 

The protection is removed, and the 
workbook is editable again. 
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Password Protection 

When a password is added to a workbook, only authorized users with the password can view or modify it. 

Add Password Protection 
Click the File tab. 

Click Save As. 

Click Browse. 

Click Tools. 

Select General Options. 
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Enter passwords in the 
password text boxes as 
desired. 

• Password to open: Enter a 
password here to require 
users to enter a password to 
view the workbook. This 
password is encrypted, 
making it more secure. 

• Password to modify: Enter a 
password here to require 
users to enter a password to 
save changes to the 
workbook. This password is 
not encrypted. 

You can enter just one or both 
passwords, depending on the 
type of protection you want for 
the workbook. Passwords are 
case-sensitive. 

Tip: Check the Always create 
backup box to save a copy 
without a password incase the 
password is forgotten. 

Click OK. 

Reenter the password. 

Tip: Type a secure password 
that can't easily be guessed by 
other users, and be sure to 
write down your password in a 
safe location. 

Click OK. 
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Click Save. 

The workbook is now password 
protected. To change or remove a 
password, repeat the workbook 
protection steps and simply change or 
delete the password in the General 
Options dialog box. 
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